Opdater celle automatisk med fanearks titel

Faneark, ark, faneblad. Mange termer for det samme. Uanset hvad du kalder det, tænker vi det samme. Jeg viser dig her hvordan du navngiver en celle automatisk med samme navn som fanearket.

Du har sikkert et regneark, der skal opdateres med nye værdier f.eks. hver måned. Her plejer du at kopiere et faneblads celler til et nyt, hvorefter du indsætter nye værdier. Dette kunne være afstemning af en bestemt konto, rykkerliste, mobilforbrug eller noget helt fjerde. Det nye faneblad kalder du datoen for ajourføringen – f.eks. “01-12-2017” eller “01-12”.

Arknavn

I en celle skriver du måske samme dato som arknavnet. Kunne det ikke være fedt, hvis denne celle automatisk havde samme navn som arknavnet?

Bankafstemning

Lad Excel arbejde for dig – sådan opdaterer celle automatisk med arknavn

Lad være med at arbejde for Excel – lad Excel arbejde for dig! Lad dine Excel-ark blive automatiseret – i dette tilfælde skal der blot en enkelt funktion til for at cellen automatisk opdaterer med fanebladets navn.

I dette tænkte eksempel kalder du fanebladet “10-12” – altså 10. december i indeværende år. Ved at skrive

=MIDT(CELLE("filnavn";A1);FIND("]";CELLE("filnavn";A1))+1;255)

i cellen, kommer der til at stå præcis det samme. Men hvad gør du så hvis du gerne vil have årstal med? Du har to muligheder:

  1. Fanebladet kan navngives “10-12-2017”
  2. Du kan indkranse funktionen med tekst([funktion];"dd-mm-åååå") for at få fuld datoformat.

Jeg vil helt klart anbefale version 2, hvis dit regneark kun indeholde dette års måneder. På den måde kommer navnene på fanebladene også til at være så korte som muligt, hvilket gør at du har et bedre overblik over så mange faneblade som muligt uden at skal scrolle vandret. Indeholder dit regneark flere års faneblade kan du vælge at tilføje årstal til funktionen. Så er du fri for at se årstal på fanebladene.

Den fulde funktion vil komme se at se således ud:

=TEKST(MIDT(CELLE("filnavn";A1);FIND("]";CELLE("filnavn";A1))+1;255);"dd-mm-åååå")

På den måde arbejder Excel for dig – og ikke omvendt! Nu kan du bruge din tid på at tjene penge i stedet.

Tagged with:

Skriv et svar